Help Contents

Overview

Quick Start Guide

Portfolio Lists

Portfolios

Bubble Charts

Menus

Form Overview

This form is displayed when you open a Portfolio from the Portfolio List form.

This form is used to manage the Project data that is displayed in the associated bubble charts.

This form is opened when a Portfolio form is selected and opened from the Portfolio List form. This form is on the first page (tab) of the Portfolio form. This form is used to manage data Projects that are displayed in the bubble charts.

The top of the form displays the name of the Portfolio and buttons used to create, open, display subsets, sort, query, and delete Projects on the Portfolio.

Important! Note that the headers above each column indicate if a column is “Active“. A column must be be made “Active“ by checking the checkbox in the Column form in order for the data in the column to be available for charting.

The tabs at the top of the form lets you select between viewing the portfolio form or the bubble chart form.

The form has a menu associated with it entitled “Portfolios.” You can also print and export the data displayed in this form using the standard "Print" and "Export" menu items under the "File" menu.

You can set a number of display preferences using the Portfolio Preferences form. This form can be opened by selecting the "Preferences" menu item under the "File" menu or pressing "control-," (Windows) or "Command-," (Mac).

The Portfolio Data Form List Box:

The Portfolio list box displays the Projects and associated data for creating your bubble charts. The list box can be sorted by clicking on the header at the top of each column (except for the “Pic” column). The 1st row of the list box contains the name of each column. The data columns, denoted by alphabetical characters in the in the headers, display your customized column names in the 1st row. This name can be modified by clicking the cell to open the Modify Column form. The column data in individual cells can be modified by slow double-clicking in the cell to make the data editable.

When you click on a row containing a data Project, the “Open,” “Subset,” and “Delete” buttons become enabled. When you double-click on a data Project row, that Project Is opened for modification and saving in the data Project form.

Column Headers: Above each column is a header that indicates if a column is “Active“. A column must be be made “Active“ by checking the checkbox in the Column form in order for the data in the column to be available for charting. Clicking on a column header sorts the portfolio by the values contained in that column, except for the "Pic" (picture) column.

Select column (Sel.): This is the 1st column in the list box. This column lets you select data Projects by checking and unchecking them. When you click on a cell in this column, the display toggles between checked and unchecked. When you click at the top of the column, the list box Projects are sorted by checked and unchecked. The checkbox just above the select column lets you toggle between the selection of all the Projects (all Projects checked) and all Projects unselected (all Projects unchecked).

Number column (No.): This column simply displays the current Project numbering. The numbering changes depending on the number of Projects displayed. For example, if you display 10 Projects they will be numbered 1 through 10, however, if you create a subset of those Projects using the Subset button, those 3 Projects will be numbered 1 to 3, and those numbers may be different than they were when there were 10 Projects displayed.

You can sort this column by clicking on the header at the top of the column.

Name column: The name column displays the names of the individual data Projects. You can customize the column name by clicking in the top row. Project names can not exceed 32 characters and cannot be duplicated within an individual Portfolio. You can edit project names by slowly double-clicking in the column row to make the selected cell editable.

Picture column: This column displays the color/pattern combination that will be used in the bubbles on the bubble chart. The color/pattern combination can be edited in the Project form. This column is not sortable or editable.

The columns: These columns display the data associated with each Project. You can name and format the column data by clicking on the 1st row to open up the column name form. After you save the new name, it is displayed in the 1st row of the column. In Bubble Chart Pro™ plus, this is where you also assign the column weight for calculating the value score. There are 100 data columns in a Portfolio, and all of these columns can be used in bubble charts.

A slow double-click in the column cells will make the particular cell editable so that you can modify the data directly. A fast double-click on a row will open the selected Project in the Project data form, and you can change the data using that form, too.

Categorical data can be changed by clicking the cell, and selecting from a popup menu that appears containing the categories that were added in the Modify Column form.

When you modify data in the Portfolio form, you can undo your changes by selecting the "Undo" menu item from the "Edit" or selecting the control-z (Windows) or command-z (Mac) after making a change. Multiple Undo's can be performed while portfolio form is open, however, all changes are saved after the chart is closed. Changes to portfolio data made outside the form, such as modifying project data in a project form, cannot be reversed by using the "Undo" function.

At the bottom of each column, the associated statistics are automatically displayed:

Changing Column Order:

You can re-arrange the order of the data columns by dragging the column by the column header and dropping the column in the new location as illustrated below. You can restore the original column order by checking the [Restore Original Column Order] check box in the Portfolio Preferences form, and then saving and closing the form.

The Portfolio Data Form Buttons:

[Cont.] (Contract column width) button: Click on the [Cont.] button to toggle width of the data columns to an equal width. After this button has been clicked, it is toggled to the [Exp.] button.

[Exp.] (Expand column width) button: Click on the [Exp.] button to toggle width of the data columns to view the full column names in the top row. After this button has been clicked, it is toggled to the [Cont.] button.

[New] button: Click this button to display the New Project form. Use this form to add new Projects to the Portfolio.

[Open] button: After highlighting an Project in the Portfolio by clicking on a row in the Portfolio list, click on this button to open the highlighted Projects in the Project forms for viewing or editing. (Alternatively, you can open a Project by double-clicking on it.) This button is disabled unless one or more Projects are highlighted in the Portfolio form.

[All] button: Click on this button to display all of the Projects in the Portfolio.

[Subset] button: After holding down the Shift key (or Command Key on the Mac) and clicking on several Projects to highlight them in the Portfolio form, click on this button to display only the selected Projects. This allows you to easily view subsets of Projects from the Portfolio. Clicking on [Show All] will redisplay all of the Projects. When you have a bubble chart open, the bubble chart is automatically redrawn to display only the Projects shown in the subset of the data form. This allows you to quickly model different groups of projects. This button is disabled unless one or more Projects are highlighted in the Portfolio form.

[Sort] button: Click on the [Sort] button to open the Sort form and perform complex sorts on your data

[Query] button: Click on the [Query] button to open the Query form and perform complex queries of your data

[Delete] button: After highlighting one or more Projects in the Portfolio, click on this button to delete the selected set. The form will then display the set of Projects that you have selected to delete, and you will be asked to confirm that you want to delete the displayed Projects. If you click [Delete] in this form, all of these Projects will be deleted from the Portfolio. This action cannot be undone. Click [Cancel] to return to the form without deleting the Projects. This button is disabled unless one or more Projects are highlighted in the Portfolio form.

[Close] button: Click on this button to close the Portfolio form.

The Portfolio Menu Items:

“New Project...”: This menu Project corresponds in functionality to the [New] button.

“Open Selected Project”: This menu Project corresponds in functionality to the [Open] button.

“Delete Selected Projects...”: This menu Project corresponds in functionality to the [Delete] button.

“Query...”: This menu Project corresponds in functionality to the [Query] button.

“Sort...”: This menu Project corresponds in functionality to the [Sort] button.

“Modify Selection...”: This menu Project is enabled when one or more Projects are selected in the Portfolio. Selecting this Project opens the Modify Selection form, which lets you modify column values, colors, patterns, selection, etc. for the selected subset of projects.

“Create Import Template...”: This menu Project lets you create and save a text file that you can open and edit in a spreadsheet program and then use to import the data into Bubble Chart Pro™.

“Import From Template...”: This menu begins a dialog that lets you import data into Bubble Chart Pro™ from an edited import template.